package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{1,3})(\d{1,3})?(\d{1,4})?`)
var str = `0
01
012
0123
01234
012345
0123456
01234567
012345678
0123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}