import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,3})(\\d{1,3})?(\\d{1,4})?";
final String string = "0\n"
+ "01\n"
+ "012\n"
+ "0123\n"
+ "01234\n"
+ "012345\n"
+ "0123456\n"
+ "01234567\n"
+ "012345678\n"
+ "0123456789";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}