import Foundation
let pattern = #"(\d{1,3})(\d{1,3})?(\d{1,4})?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0
01
012
0123
01234
012345
0123456
01234567
012345678
0123456789
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)