using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,3})(\d{1,3})?(\d{1,4})?";
string input = @"0
01
012
0123
01234
012345
0123456
01234567
012345678
0123456789";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}