$re = '/(\d{1,3})(\d{1,3})?(\d{1,4})?/';
$str = '0
01
012
0123
01234
012345
0123456
01234567
012345678
0123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);