const regex = /(\d{1,3})(\d{1,3})?(\d{1,4})?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,3})(\\d{1,3})?(\\d{1,4})?', 'g')
const str = `0
01
012
0123
01234
012345
0123456
01234567
012345678
0123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}