# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div class="dotted-highlight">\K[^<]+(?=<ul>)/<strong>$0<\/strong>/gi;t' <<< "<div class=\"dotted-highlight\">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>"