const regex = new RegExp('<div class="dotted-highlight">\\K[^<]+(?=<ul>)', 'gi')
const str = `<div class="dotted-highlight">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>`;
const subst = `<strong>$0</strong>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);