use strict;
my $str = '<div class="dotted-highlight">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>';
my $regex = qr~<div class="dotted-highlight">\K[^<]+(?=<ul>)~ip;
my $subst = '<strong>$0</strong>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";