import Foundation
let pattern = #"<div class="dotted-highlight">\K[^<]+(?=<ul>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<div class="dotted-highlight">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<strong>$0</strong>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)