import re
regex = re.compile(r"<div class=\"dotted-highlight\">\K[^<]+(?=<ul>)", flags=re.IGNORECASE)
test_str = ("<div class=\"dotted-highlight\">So, to sum up your own appearance:\n"
"<ul>\n"
"<li>Your hair must be neat and tidy.</li>")
subst = "<strong>$0</strong>"
result = regex.sub(subst, test_str)
if result:
print(result)