$re = '~<div class="dotted-highlight">\K[^<]+(?=<ul>)~i';
$str = '<div class="dotted-highlight">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>';
$subst = "<strong>$0</strong>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;