using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""dotted-highlight"">\K[^<]+(?=<ul>)";
string substitution = @"<strong>$0</strong>";
string input = @"<div class=""dotted-highlight"">So, to sum up your own appearance:
<ul>
<li>Your hair must be neat and tidy.</li>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}