import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"dotted-highlight\">\\K[^<]+(?=<ul>)";
final String string = "<div class=\"dotted-highlight\">So, to sum up your own appearance:\n"
+ "<ul>\n"
+ "<li>Your hair must be neat and tidy.</li>";
final String subst = "<strong>$0</strong>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}