package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:.|\n)*)\n\nExcerpt(?:(?:.|\n)*)`)
var str = `We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did
Excerpt from: "2 Samuel: Your Kingdom Come" by John Woodhouse. Scribd.
This material may be protected by copyright.
Read this book on Scribd: https://www.scribd.com/book/284612094
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}