# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:.|\n)*)\n\nExcerpt(?:(?:.|\n)*)"
test_str = ("We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did\n\n"
"Excerpt from: \"2 Samuel: Your Kingdom Come\" by John Woodhouse. Scribd.\n"
"This material may be protected by copyright.\n\n"
"Read this book on Scribd: https://www.scribd.com/book/284612094\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.