use strict;
my $str = 'We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did
Excerpt from: "2 Samuel: Your Kingdom Come" by John Woodhouse. Scribd.
This material may be protected by copyright.
Read this book on Scribd: https://www.scribd.com/book/284612094
';
my $regex = qr/((?:.|\n)*)\n\nExcerpt(?:(?:.|\n)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}