// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:.|\n)*)\n\nExcerpt(?:(?:.|\n)*)").unwrap();
let string = "We know what David was talking about, even if, perhaps, many of us do not know it as intensely and as often as he did
Excerpt from: \"2 Samuel: Your Kingdom Come\" by John Woodhouse. Scribd.
This material may be protected by copyright.
Read this book on Scribd: https://www.scribd.com/book/284612094
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}