# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(src=")(.*")/$1domain.com\/$2/gU;t' <<< "<img src=\"uploads/1.jpg\"> Привет <img src=\"uploads/2.gif\">"