const regex = /(src=")(.*")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(src=")(.*")', 'g')
const str = `<img src="uploads/1.jpg"> Привет <img src="uploads/2.gif">`;
const subst = `$1domain.com/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);