$re = '/(src=")(.*")/U';
$str = '<img src="uploads/1.jpg"> Привет <img src="uploads/2.gif">';
$subst = "$1domain.com/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;