re = /(src=")(.*")/
str = '<img src="uploads/1.jpg"> Привет <img src="uploads/2.gif">'
subst = '$1domain.com/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result