// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?U)(src=")(.*")"#).unwrap();
let string = "<img src=\"uploads/1.jpg\"> Привет <img src=\"uploads/2.gif\">";
let substitution = "$1domain.com/$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}