#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?U)(src=")(.*")"
Local $sString = "<img src="uploads/1.jpg"> Привет <img src="uploads/2.gif">"
Local $sSubst = "$1domain.com/$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)