package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)(src=")(.*")`)
var str = `<img src="uploads/1.jpg"> Привет <img src="uploads/2.gif">`
var substitution = "$1domain.com/$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}