#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "1[5-9]\d{2,}|[2-9]\d{3,}|1\d{4,}"
Local $sString = "800" & @CRLF & _
"0800" & @CRLF & _
"1234" & @CRLF & _
"1511" & @CRLF & _
"1555" & @CRLF & _
"1789" & @CRLF & _
"2111" & @CRLF & _
"2345" & @CRLF & _
"3456" & @CRLF & _
"56756" & @CRLF & _
"123123" & @CRLF & _
"123123123" & @CRLF & _
"159999999999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")