import re
regex = re.compile(r"1[5-9]\d{2,}|[2-9]\d{3,}|1\d{4,}")
test_str = ("800\n"
"0800\n"
"1234\n"
"1511\n"
"1555\n"
"1789\n"
"2111\n"
"2345\n"
"3456\n"
"56756\n"
"123123\n"
"123123123\n"
"159999999999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")