package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`1[5-9]\d{2,}|[2-9]\d{3,}|1\d{4,}`)
var str = `800
0800
1234
1511
1555
1789
2111
2345
3456
56756
123123
123123123
159999999999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}