// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"1[5-9]\d{2,}|[2-9]\d{3,}|1\d{4,}").unwrap();
let string = "800
0800
1234
1511
1555
1789
2111
2345
3456
56756
123123
123123123
159999999999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}