import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1[5-9]\\d{2,}|[2-9]\\d{3,}|1\\d{4,}";
final String string = "800\n"
+ "0800\n"
+ "1234\n"
+ "1511\n"
+ "1555\n"
+ "1789\n"
+ "2111\n"
+ "2345\n"
+ "3456\n"
+ "56756\n"
+ "123123\n"
+ "123123123\n"
+ "159999999999";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}