using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1[5-9]\d{2,}|[2-9]\d{3,}|1\d{4,}";
string input = @"800
0800
1234
1511
1555
1789
2111
2345
3456
56756
123123
123123123
159999999999";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}