#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((ftp|https?):\/\/|(www\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\S*[^\s.;,(){}<>"\u201d\u2019]"
Local $sString = ""{\"value\": "https://example.com/path\"},{\"foo\":\"{‡€°"‹Ó}\",\"bar\":null"}"" & @CRLF & _
" ^ ^" & @CRLF & _
" it should have stopped here special chars shouldn't match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")