import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((ftp|https?):\\/\\/|(www\\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\\S*[^\\s.;,()\\{\\}<>\"\\u201d\\u2019]";
final String string = "\"{\\\"value\\\": \"https://example.com/path\\\"},{\\\"foo\\\":\\\"{‡€°\"‹Ó}\\\",\\\"bar\\\":null\"}\"\n"
+ " ^ ^\n"
+ " it should have stopped here special chars shouldn't match";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}