re = /((ftp|https?):\/\/|(www\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\S*[^\s.;,(){}<>"\u201d\u2019]/i
str = '"{\\"value\\": "https://example.com/path\\"},{\\"foo\\":\\"{‡€°"‹Ó}\\",\\"bar\\":null"}"
^ ^
it should have stopped here special chars shouldn\'t match'
# Print the match result
str.match(re) do |match|
puts match.to_s
end