package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((ftp|https?):\/\/|(www\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\S*[^\s.;,(){}<>"\u201d\u2019]`)
var str = `"{\"value\": "https://example.com/path\"},{\"foo\":\"{‡€°"‹Ó}\",\"bar\":null"}"
^ ^
it should have stopped here special chars shouldn't match`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}