$re = '/((ftp|https?):\/\/|(www\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\S*[^\s.;,(){}<>"\u201d\u2019]/i';
$str = '"{\\"value\\": "https://example.com/path\\"},{\\"foo\\":\\"{‡€°"‹Ó}\\",\\"bar\\":null"}"
^ ^
it should have stopped here special chars shouldn\'t match';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);