using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((ftp|https?):\/\/|(www\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\S*[^\s.;,(){}<>""\u201d\u2019]";
string input = @"""{\""value\"": ""https://example.com/path\""},{\""foo\"":\""{‡€°""‹Ó}\"",\""bar\"":null""}""
^ ^
it should have stopped here special chars shouldn't match";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}