const regex = /((ftp|https?):\/\/|(www\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\S*[^\s.;,(){}<>"\u201d\u2019]/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((ftp|https?):\\\/\\\/|(www\\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\\S*[^\\s.;,(){}<>"\\u201d\\u2019]', 'i')
const str = `"{\\"value\\": "https://example.com/path\\"},{\\"foo\\":\\"{‡€°"‹Ó}\\",\\"bar\\":null"}"
^ ^
it should have stopped here special chars shouldn't match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}