import re
regex = re.compile(r"((ftp|https?):\/\/|(www\.)|(mailto:)?[A-Za-z0-9._%+-]+@)\S*[^\s.;,(){}<>\"\u201d\u2019]", flags=re.IGNORECASE)
test_str = ("\"{\\\"value\\\": \"https://example.com/path\\\"},{\\\"foo\\\":\\\"{‡€°\"‹Ó}\\\",\\\"bar\\\":null\"}\"\n"
" ^ ^\n"
" it should have stopped here special chars shouldn't match")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")