# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^.\n]+#([^#.\n]+)//gm;t' <<< "sentence#newsletter.#hello
hello#music
#hello#music
hello.com#music"