re = /^[^.\n]+#([^#.\n]+)/m
str = 'sentence#newsletter.#hello
hello#music
#hello#music
hello.com#music'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result