using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^.\n]+#([^#.\n]+)";
string substitution = @"";
string input = @"sentence#newsletter.#hello
hello#music
#hello#music
hello.com#music";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}