import re
regex = re.compile(r"^[^.\n]+#([^#.\n]+)", flags=re.MULTILINE)
test_str = ("sentence#newsletter.#hello\n"
"hello#music\n"
"#hello#music\n"
"hello.com#music")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)