const regex = /^[^.\n]+#([^#.\n]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^.\\n]+#([^#.\\n]+)', 'gm')
const str = `sentence#newsletter.#hello
hello#music
#hello#music
hello.com#music`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);