$re = '/^[^.\n]+#([^#.\n]+)/m';
$str = 'sentence#newsletter.#hello
hello#music
#hello#music
hello.com#music';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;