// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^.\n]+#([^#.\n]+)").unwrap();
let string = "sentence#newsletter.#hello
hello#music
#hello#music
hello.com#music";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}