package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.\n]+#([^#.\n]+)`)
var str = `sentence#newsletter.#hello
hello#music
#hello#music
hello.com#music`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}