package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}`)
var str = `<a href="#" title="Sample Fee – also see B11023">G14015</a>`
var substitution = "B"
fmt.Println(re.ReplaceAllString(str, substitution))
}