const regex = /(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)<[^>]+(*SKIP)(*F)|[a-z]?\\d{5}', 'gm')
const str = `<a href="#" title="Sample Fee – also see B11023">G14015</a>`;
const subst = `B`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);