re = /(?i)<[^>]+(*SKIP)(*F)|[a-z]?\d{5}/m
str = '<a href="#" title="Sample Fee – also see B11023">G14015</a>'
subst = 'B'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result